MX5 owners!! Advice please...

MX5 owners!! Advice please...

Postby ChrisSweetleaf » Fri Oct 04, 2019 12:29 pm

I could see from the autosolo at brands hatch that we have one or two MX5 owners in the club...

I have an issue where it's pulling to the left quite a bit when under acceleration and pulling back to the right when deceleration.
Is there a common issue should check or just look for tyre pressure, loose tie rod or suspension issue?

Many thanks. Chris.
ChrisSweetleaf
 
Posts: 1
Joined: Fri Sep 29, 2017 4:31 pm

Re: MX5 owners!! Advice please...

Postby Colin S » Sun Oct 06, 2019 12:55 pm

What mark of MX5 are we talking about?

First check Tyre pressures are all equal and correct and that they are the same make and size all round (Mx5s do not like different makes of Tyre on front and rear axles)

Have a look underneath to see if anything is obviously loose, especially around the rear end.

Get a full alignment done on a Hunter Douglas or similar machine by a specialist - more important on some marks than others-NC was particularly prone to misalignment even when new. This will also hopefully show up if there are and problems with wishbone bushes etc. You may need to invest in some spare adjustment bolts as the originals may be seized, give them a good soaking in penetrating fluid several times before taking it in.

Hope this helps
User avatar
Colin S
 
Posts: 161
Joined: Thu Jul 18, 2013 2:26 pm


Return to Chit Chat

Who is online

Users browsing this forum: No registered users and 2 guests

cron